PHP | Jquery | Css | Codeigniter | Unity3D


Wordpress ile çalışırken sayfaya css ve javascript eklemek için eklenti kurmanız gerekmektedir. Bu tür durumlarda sayfaya eklediğiniz jquery kodları "$" işareti kullanılarak yazılan jquery kodlarını çoğunlukla çalıştırmamakta ve browser konsolundan ya da firebug dan baktığınızda hata olarak göstermektedir. Bu tür bir sorunla normal bir html sayfada da karşılaşmanız mümkün bu da sunucunuza bağlı olarak veya kullandığınız jquery kütüphanesi sürümüne göre değişkenlik gösterebilmektedir. Bu tür durumlarda "$" işareti yerine "jQuery" ifadesini kullanmanız sorunu aşmanıza yardımcı olacaktır. Burda dikkat etmeniz gereken tüm "$" ifadelerini "jQuery" ifadesiyle değiştirmeniz gerekmesidir ve bunu dosyanızı bir editörde açıp find and replace yöntemi ile eksiksiz olarak yapabilirsiniz. Sorunu nasıl aşarız ona bakalım.


$(document).ready(function(){ // Hata veren kullanım.

  // Kodlar

});


jQuery(document).ready(function(){ // Düzeltmeniz gerektiği gibi.

  // Kodlar

});

Diğer bir alternatif kullanım ise;


$j = jQuery.noConflict();
 
$j(document).ready(function(){ // Düzeltmeniz gerektiği gibi.

  // Kodlar

});



Soru ve Tartışma Konularınız için;

Yayınlayan
comments powered by Disqus
Yazar: Windofelm
Description: Wordpress de bazen jquery kodları çalışmayabilir bu kurduğunuz eklentiye göre değişiklilik göstermektedir.